Pontiac Grand Prix Forums : Grandprix
 

Grand Prix Forums is the premier Pontiac Forum on the internet. Registered Users do not see the above ads. Please Register - It's Free!

Pontiac Grand Prix Forum - Welcome Register today! Contact us!

Results 1 to 9 of 9
  1. #1
    SE Level Member
    Join Date
    Dec 2010
    Location
    UT
    Posts
    6
    Chats
    0

    Default External temperature reading is way low - A/C blows hot air

    Hello,

    I noticed that occasionally when I start my Grand Prix 1998 the external temperature reading shows low or negative numbers, e.g. -29F, even if the temperature is over 100F outside. This seems to cause A/C to blow warm/hot air since it thinks that temperature outside is cool enough and doesn't need additional cooling.

    When I start driving the car and reach and maintain the speed of 65 mph or higher the temperature reading starts climbing and in a couple of minutes A/C starts blowing cold. I can achieve the same effect by cracking the driver and passenger windows open.

    Online I found another complaint about a similar problem and the recommendation was to change temperature sensor. So, I changed the temperature sensor but that didn't fix the problem.

    Any thoughts on this?

    Thanks,

    Alec

  2. #2
    Killa Bee Scottydoggs's Avatar
    Join Date
    Aug 2010
    Location
    new jersey
    Posts
    37,531
    Chats
    155622

    Default Re: External temperature reading is way low - A/C blows hot air

    that should be the outside temp sensor, its located in front of the radiator, clipped to the frame work in the bumper area. they cost like 12 bucks or so from the dealer.

    98 Buick Regal GS, F body brakes, Caddy STS wheels, tinted tails L36 bottom end, lightly ported heads, 1.95 roller rockers, headers, 2.8, FSIC, 42 lb injectors, a BrandonHall rebuilt trans, DHP tuned and AEM water/Meth injection https://goo.gl/gpV5kW

  3. #3
    Turbo is the way to go. Fivefingerdeathpunch's Avatar
    Join Date
    Sep 2009
    Location
    Rogers, MN
    Posts
    20,608
    Chats
    80891

    Default Re: External temperature reading is way low - A/C blows hot air

    He said he changed it already.

    So its possible its a bad sensor again or something in the circut.

    SMGPFC Member #1

  4. #4
    Killa Bee Scottydoggs's Avatar
    Join Date
    Aug 2010
    Location
    new jersey
    Posts
    37,531
    Chats
    155622

    Default Re: External temperature reading is way low - A/C blows hot air

    bad wires to the plug?

    98 Buick Regal GS, F body brakes, Caddy STS wheels, tinted tails L36 bottom end, lightly ported heads, 1.95 roller rockers, headers, 2.8, FSIC, 42 lb injectors, a BrandonHall rebuilt trans, DHP tuned and AEM water/Meth injection https://goo.gl/gpV5kW

  5. #5
    SE Level Member
    Join Date
    Dec 2010
    Location
    UT
    Posts
    6
    Chats
    0

    Default Re: External temperature reading is way low - A/C blows hot air

    Yes, I replaced the temp sensor located in front of the radiator.

    scottydoggs, are you referring to the wires leading to the temp sensor plug? Why would driving with 65 mph speed fix this?

  6. #6
    Killa Bee Scottydoggs's Avatar
    Join Date
    Aug 2010
    Location
    new jersey
    Posts
    37,531
    Chats
    155622

    Default Re: External temperature reading is way low - A/C blows hot air

    flux capacitor? what happens at 88 mph?


    i have no idea, seems quite odd.

    the wires could have cracked insulation or the insulation ends have pulled from the plug some. either way any bare wire can mess up the signal to and from the sensor. its a free check to just look at them close, follow them as far as you can.

    98 Buick Regal GS, F body brakes, Caddy STS wheels, tinted tails L36 bottom end, lightly ported heads, 1.95 roller rockers, headers, 2.8, FSIC, 42 lb injectors, a BrandonHall rebuilt trans, DHP tuned and AEM water/Meth injection https://goo.gl/gpV5kW

  7. #7
    SE Level Member RonsGTP's Avatar
    Join Date
    Apr 2015
    Location
    San Antonio, Texas
    Posts
    16
    Chats
    0

    Default Re: External temperature reading is way low - A/C blows hot air

    Having this same issue. Wondering if this ever got fixed and if so what was the fix?
    1999 Black GTP (stock)
    2017 ZL1 (Red Hot)
    2016 Camaro SS (wife's car)

  8. #8
    GT Level Member wstefan20's Avatar
    Join Date
    Aug 2017
    Location
    Raytown, MO
    Posts
    163
    Chats
    4

    Default Re: External temperature reading is way low - A/C blows hot air

    I can almost promise you the issue is the low reference wire. I just spent the time involved to completely gut and install the automatic hvac you have and discovered that the sunload sensor, both door actuators, external, and internal sensors all share the same low reference (sensor gound wire) that goes to the hvac unit. If one of the wires in this system are shorting to chassis ground, then the temperature will as well.

    Also, strangely enough, sometimes it is a calibration issue, or the hvac control unit issue. To re-calibrate, disconnect battery for a minute, reconnect, then turn key to accessory and DO NOT touch the hvac at all! I cannot stress this enough. Doing so will disrupt the learn cycle of the unit and you will have to start over again. Now start the car after it starts to blow air and leave it for another minute. Now check the readings and functions of your system.

    Usually if it is a grounding issue, the temperature will ground to 55 degrees and you will have more issues with the blend doors, so I would wager on the hvac control unit itself. Unfortunately they are prone to failure.

    The other frustrating thing about this system is that if any of the aforementioned parts actually short out for some reason to common, they take the WHOLE system out with it causing symptoms as you describe, other than replacing all the wiring and components one by one, its hard to pinpoint the issue.

    The only sure-fire way of troubleshooting is to run a line test on both sensor reference wire and outside temp sensor wire to see if either are shorting, and then I would replace the hvac head unit.

  9. #9
    SE Level Member RonsGTP's Avatar
    Join Date
    Apr 2015
    Location
    San Antonio, Texas
    Posts
    16
    Chats
    0

    Default Re: External temperature reading is way low - A/C blows hot air

    ok thanks. I just tried the reset function you describe above and the actual current temp is 90 but the car went straight to 80 then slowly dropped to 73. Maybe i'll replace the sensor and try this reset process again.
    1999 Black GTP (stock)
    2017 ZL1 (Red Hot)
    2016 Camaro SS (wife's car)

Similar Threads

  1. External Trans Cooler
    By ls1camino in forum 1997-2007 4 speed Automatic (4T65E) (4T65E-HD)
    Replies: 3
    Last Post: 04-30-2012, 12:34 PM
  2. My Ice Box set-up and external PCV catch can
    By kygtp in forum General Tech Discussion
    Replies: 7
    Last Post: 01-25-2012, 07:04 PM
  3. Exterior Temperature reading wrong
    By 2000GrandPrixGT2000 in forum General Tech Discussion
    Replies: 1
    Last Post: 09-07-2010, 04:49 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •