Pontiac Grand Prix Forums : Grandprix
 

Grand Prix Forums is the premier Pontiac Forum on the internet. Registered Users do not see the above ads. Please Register - It's Free!

Pontiac Grand Prix Forum - Welcome Register today! Contact us!

Results 1 to 3 of 3
  1. #1
    SE Level Member andante147's Avatar
    Join Date
    May 2010
    Location
    Winfield, IL (DuPage)
    Posts
    45
    Chats
    140

    Default Water in LR brake light housing/ABS light

    Just bought my '03 GTP. Has 124K on it, very clean and runs great. It's having the ABS and Traction control light problem, and I'm in the process of deciding what steps to take on that. The guy I bought it from had some hubs/sensors replaced not too long ago, but they might be bad again.

    Here's my question.... there was a LOT of water in the right rear taillight housing. I dumped and blew out as much as I could but it's not completely gone.

    Could this cause the ABS light (i.e. electrical issue from the water)?

    Is there a way to keep this housing dry?

    If I have to replace, all I find so far is OEM. Don't I want something improved? Where should I look for it?

    Thanks

  2. #2
    GTX Level Member Jakegday's Avatar
    Join Date
    Nov 2008
    Location
    Fremont Nebraska
    Posts
    585
    Chats
    9

    Default Re: Water in LR brake light housing/ABS light

    there is simply no way in hell water in the taillight could be causing the ABS light.
    you either have a bad front hub/bearing, or a bad connection between a front wheel bug/bearing and the computer it goes to. check the wiring.

    the taillight housing is a very common problem. when it happened to me i got 1 on ebay for $30 in new condition
    2001 GT: cat/ubend/resonator delete, zzp PLOG, custom intake, DHP pcm

  3. #3
    SE Level Member
    Join Date
    May 2010
    Location
    Dallas
    Posts
    3
    Chats
    0

    Default Re: Water in LR brake light housing/ABS light

    I am having the same issue with my 04 GP. I was told that the hub sensor went out which in turn caused the abs module to go out. I had the new hub put on and I purchased a used module put on. It corrected the problem for a a month and now I am having the same problem again. Not sure what to do at this point.

Similar Threads

  1. metal lightbulb shield inside light housing? is it needed or not
    By Joe m in forum Audio, Security & Visual Electronics
    Replies: 55
    Last Post: 11-17-2010, 05:26 AM
  2. Replies: 16
    Last Post: 01-23-2010, 08:43 AM
  3. removing dome light housing
    By 2000GTP in forum Visual/Body Modifications
    Replies: 1
    Last Post: 01-16-2010, 05:45 PM
  4. my 4th brake light and 3rd reverse light
    By HART in forum Visual/Body Modifications
    Replies: 6
    Last Post: 11-05-2009, 12:33 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •