Pontiac Grand Prix Forums : Grandprix
 

Grand Prix Forums is the premier Pontiac Forum on the internet. Registered Users do not see the above ads. Please Register - It's Free!

Pontiac Grand Prix Forum - Welcome Register today! Contact us!

Page 2 of 2 FirstFirst 12
Results 21 to 35 of 35
  1. #21
    DUI BABY Bio248's Avatar
    Join Date
    Jan 2008
    Location
    MILWAUKEE
    Posts
    31,413
    Chats
    40479

    Default Re: Low Oil Level Light Still Comes On After Low Oil Level Sensor Replacement

    the sensor in the pan is for oil level. you shouldnt have to ever see that light because you check your dipstick every so often, right?

    the sensor on the oil pump housing is for oil pressure. if that light ever comes on it's too late because it only comes on when it sees less than 5psi and that's way too low. expect a new bottom end if you're seeing this light.

  2. #22
    GT Level Member andremike's Avatar
    Join Date
    Nov 2009
    Location
    chicago
    Posts
    325
    Chats
    0

    Default Re: Low Oil Level Light Still Comes On After Low Oil Level Sensor Replacement

    The OP and myself are talking about the low oil level light on the right side of the cluster. This is the sensor in the oil pan that determines if you are low on oil.. And I did check my dipstick and there is plenty of oil in there..

    I guess I should of just left the old sensor in there...

  3. #23
    GT Level Member andremike's Avatar
    Join Date
    Nov 2009
    Location
    chicago
    Posts
    325
    Chats
    0

    Default Re: Low Oil Level Light Still Comes On After Low Oil Level Sensor Replacement

    Any other ideas? Bringing my car in for the third time..

  4. #24
    SE Level Member
    Join Date
    Apr 2011
    Location
    Cleveland, Ohio
    Posts
    2
    Chats
    0

    Default Re: Low Oil Level Light Still Comes On After Low Oil Level Sensor Replacement

    I have a 97 Grand Prix with the exact same problem.. the oil level light sometimes comes on but never when I restart the engine again.. changing the sensor nor the connector helped.. Has anyone found the solution? Thanks

  5. #25
    GTP Level Member Burbman's Avatar
    Join Date
    Dec 2008
    Location
    Islip, Long Island!
    Posts
    823
    Chats
    127

    Default Re: Low Oil Level Light Still Comes On After Low Oil Level Sensor Replacement

    Have the same problem with the 98, exact symptoms. Replaced the sensor and no change.

    Sent from my SPH-L720 using Tapatalk
    2002 GTP Coupe, PSE supercharger ported with 3.4 pulley, Wizaired CAI, ZZP tune, AL 104's, front Plog, 3" DP, u-bend gone, hi-flo cat, W-Body tubular trailing and lateral arms, GMPP sway bars, Vogtland springs, 245/45-18 Michelin Pilot Sport AS/3 on 18x8 wheels, 42mm offset, Dual Aeroforce interceptor gauges on A-pillar pod

  6. #26
    GT Level Member
    Join Date
    Dec 2013
    Location
    Enfield
    Posts
    354
    Chats
    0

    Default Re: Low Oil Level Light Still Comes On After Low Oil Level Sensor Replacement

    Maybe next oil change do a Risolene engine flush before changing the oil. If this is somehow caused by a sludge build up condition it could help, either way wont hurt and it only puts you out about 5 bucks.

  7. #27
    GTP Level Member Burbman's Avatar
    Join Date
    Dec 2008
    Location
    Islip, Long Island!
    Posts
    823
    Chats
    127

    Default Re: Low Oil Level Light Still Comes On After Low Oil Level Sensor Replacement

    No sludge on the 98, I only changed the sensor because I changed the pan and gasket.

    Sent from my SPH-L720 using Tapatalk
    2002 GTP Coupe, PSE supercharger ported with 3.4 pulley, Wizaired CAI, ZZP tune, AL 104's, front Plog, 3" DP, u-bend gone, hi-flo cat, W-Body tubular trailing and lateral arms, GMPP sway bars, Vogtland springs, 245/45-18 Michelin Pilot Sport AS/3 on 18x8 wheels, 42mm offset, Dual Aeroforce interceptor gauges on A-pillar pod

  8. #28
    GTX Level Member EJOUIE's Avatar
    Join Date
    Mar 2010
    Location
    Newnan, GA
    Posts
    1,192
    Chats
    19

    Default Re: Low Oil Level Light Still Comes On After Low Oil Level Sensor Replacement

    Changed the pan? Nice. Thats not as simple as it sounds.

    I have gone through 2 oil sending units since this original post. Seems to take care of the problem for a good while.

    Also the 20w-50 was just an experiment (mechanic had me come by and check oil pressure a few times to see what was going on). Next oil change went back to 10-30 and replaced sender the first time.
    97 GT white 4 door-SOLD

    Cherry 2005 Impala LS- Front and Rear GMPP Strut Tower Braces

  9. #29
    SE Level Member
    Join Date
    Dec 2011
    Location
    Okc
    Posts
    21
    Chats
    0

    Default Re: Low Oil Level Light Still Comes On After Low Oil Level Sensor Replacement

    I am having this exact same problem.

    My oil level notice in my 2007 would come on a few times a week at startup. I change the sensor and now it comes on everytime its cold. It doesn't do it when the engine is warm.

    The replacement was a brand new acdelco unit. Any suggestions on how to clean the connector to the sensor? It's the only thing I can think that might help.

  10. #30
    GTX Level Member EJOUIE's Avatar
    Join Date
    Mar 2010
    Location
    Newnan, GA
    Posts
    1,192
    Chats
    19

    Default Re: Low Oil Level Light Still Comes On After Low Oil Level Sensor Replacement

    Just to update this as my case was resolved 100%.

    Apparently I hit something dead center on the oil pan. This damaged the oil pickup.

    The pressure was verified with a mechanical guage. Low after 3,000 miles on castrol 10-30 synthetic high mileage. Normal after oil change with the same stuff.

    Damaged pick up caused the top oil in the pan to immediately go back into the engine. Wearing out the oil much faster than normal. Thus causing the low pressure.

    So, by looking at my earlier post as a start date, I drove it 60,000 miles like that. Then traded it in.

    Sent from my SM-G920P using Tapatalk
    97 GT white 4 door-SOLD

    Cherry 2005 Impala LS- Front and Rear GMPP Strut Tower Braces

  11. #31
    SE Level Member
    Join Date
    Dec 2011
    Location
    Okc
    Posts
    21
    Chats
    0

    Default Re: Low Oil Level Light Still Comes On After Low Oil Level Sensor Replacement

    Quote Originally Posted by EJOUIE View Post
    Just to update this as my case was resolved 100%.

    Apparently I hit something dead center on the oil pan. This damaged the oil pickup.

    The pressure was verified with a mechanical guage. Low after 3,000 miles on castrol 10-30 synthetic high mileage. Normal after oil change with the same stuff.

    Damaged pick up caused the top oil in the pan to immediately go back into the engine. Wearing out the oil much faster than normal. Thus causing the low pressure.

    So, by looking at my earlier post as a start date, I drove it 60,000 miles like that. Then traded it in.

    Sent from my SM-G920P using Tapatalk

    Are you saying the low oil sensor has anothing to do with the oil level in your case, and just was just based on low pressure?

  12. #32
    GTX Level Member EJOUIE's Avatar
    Join Date
    Mar 2010
    Location
    Newnan, GA
    Posts
    1,192
    Chats
    19

    Default Re: Low Oil Level Light Still Comes On After Low Oil Level Sensor Replacement

    No. I had the red low oil pressure light.

    The low oil level sensor was surprisingly accurate.

    Sent from my SM-G920P using Tapatalk
    97 GT white 4 door-SOLD

    Cherry 2005 Impala LS- Front and Rear GMPP Strut Tower Braces

  13. #33
    SE Level Member
    Join Date
    Dec 2011
    Location
    Okc
    Posts
    21
    Chats
    0

    Default Re: Low Oil Level Light Still Comes On After Low Oil Level Sensor Replacement

    So over a year later, we figure out that this is the red oil 'pressure' light.... while the title says 'low oil level light' and 'low oil level sensor' and no mention of 'pressure'?

    So this has nothing to do with the title and is actually about an entirely different issue? Well so much for following this thread in hopes of resolving my issue.

  14. #34
    GTP Level Member Burbman's Avatar
    Join Date
    Dec 2008
    Location
    Islip, Long Island!
    Posts
    823
    Chats
    127

    Default Re: Low Oil Level Light Still Comes On After Low Oil Level Sensor Replacement

    Back on topic regarding Low oil LEVEL sensor, I had an idea that maybe worth trying....I sold the 98 sedan so my immediate issue is fixed....BUT....if you look at the sensor, it's basically an arm with a float on the end, essentially a float switch. I wonder if it's possible to install the switch so that it's 180* off? In other words upside down? Or if it's possible to thread it in so that the float is not exactly perpendicular to the oil level? Depending on how the threads are cut on the switch and/or pan, it may be possible to start it incorrectly so that when it threads in it winds up in the wrong orientation. Thi is just a SWAG in my part, but what else would explain it?

    Other theory is that the wiring is fragile and by unplugging/plugging in the new sensor the wiring gets damaged.
    2002 GTP Coupe, PSE supercharger ported with 3.4 pulley, Wizaired CAI, ZZP tune, AL 104's, front Plog, 3" DP, u-bend gone, hi-flo cat, W-Body tubular trailing and lateral arms, GMPP sway bars, Vogtland springs, 245/45-18 Michelin Pilot Sport AS/3 on 18x8 wheels, 42mm offset, Dual Aeroforce interceptor gauges on A-pillar pod

  15. #35
    SE Level Member RonsGTP's Avatar
    Join Date
    Apr 2015
    Location
    San Antonio, Texas
    Posts
    16
    Chats
    0

    Default Re: Low Oil Level Light Still Comes On After Low Oil Level Sensor Replacement

    My light recently started coming on too but when I check the oil its within range, only needing maybe half a quart so I topped it off but guess I really didn't have to.
    1999 Black GTP (stock)
    2017 ZL1 (Red Hot)
    2016 Camaro SS (wife's car)

Page 2 of 2 FirstFirst 12

Similar Threads

  1. at what mod level do i upgrade TB?
    By AmericanSoldier in forum General Tech Discussion
    Replies: 17
    Last Post: 03-23-2010, 02:12 PM
  2. Next Level STB's
    By 04CompG in forum Brakes/Suspension/Chassis
    Replies: 15
    Last Post: 11-23-2008, 05:45 PM
  3. Oil Level??
    By GTP4 in forum 3.8L V6 Supercharged (L67)(L32)
    Replies: 8
    Last Post: 09-04-2008, 09:15 AM
  4. oil level low
    By johnnyj773 in forum 3.8L V6 Naturally Aspirated (L36)(L26)
    Replies: 12
    Last Post: 07-07-2008, 04:10 AM
  5. GTP Level member
    By IndeedSS in forum Off Topic Discussion
    Replies: 26
    Last Post: 03-10-2008, 11:16 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •