Pontiac Grand Prix Forums : Grandprix
 

Grand Prix Forums is the premier Pontiac Forum on the internet. Registered Users do not see the above ads. Please Register - It's Free!

Pontiac Grand Prix Forum - Welcome Register today! Contact us!

Results 1 to 4 of 4
  1. #1
    SE Level Member
    Join Date
    Feb 2010
    Location
    Louisiana
    Posts
    2
    Chats
    0

    Default Terrible Shaking upon acceleration only

    hello all,
    I am trying to troubleshoot my 2000 Grandprix, have replaced CV joint and hubs, powersteering pump, and several vaccum hoses, nothing has helped at all.
    Symptoms: upon acceleration at any speed over 30 mph, the car begins shaking, the longer I drive it the worse the shaking gets. It feels like an old Motel bed you use to but a quarter in for a massage, just shakes the heck out of you. the engine smooths out going downhill or not accelerating. Going uphill the engine feels like it cannot breath and the shaking is really hard. It smooths out a bit if no acceleration is taking place and I am able to maintain about 70 mph on the hwy, but does not go away completely. Any ideas on what to look for next, at the end of my rope here.
    Allan

  2. #2

  3. #3
    SE Level Member COEBAM's Avatar
    Join Date
    Jan 2010
    Location
    LAWRENCE KS
    Posts
    12
    Chats
    0

    Default Re: Terrible Shaking upon acceleration only

    Agreed. Sounds like axle shafts.

  4. #4
    SE Level Member
    Join Date
    Feb 2010
    Location
    Louisiana
    Posts
    2
    Chats
    0

    Default Re: Terrible Shaking upon acceleration only

    Thanks for the suggestions, I will try that next!

Similar Threads

  1. Terrible MPG
    By nFavor in forum 5.3L V8 (LS4)
    Replies: 42
    Last Post: 08-27-2012, 03:00 PM
  2. Terrible knock..need some help!!!!!
    By FooteGTP in forum 3.8L V6 Supercharged (L67)(L32)
    Replies: 8
    Last Post: 07-01-2009, 11:57 AM
  3. Terrible Vibration.
    By 99LuminaLSC in forum Brakes/Suspension/Chassis
    Replies: 15
    Last Post: 12-31-2008, 09:46 AM
  4. Terrible Gas Mileage
    By TCO in forum General Tech Discussion
    Replies: 14
    Last Post: 12-16-2008, 12:01 AM
  5. CEL and terrible gas mileage
    By GreenNirvana101 in forum General Tech Discussion
    Replies: 16
    Last Post: 10-06-2008, 04:30 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •