Pontiac Grand Prix Forums : Grandprix
 

Grand Prix Forums is the premier Pontiac Forum on the internet. Registered Users do not see the above ads. Please Register - It's Free!

Pontiac Grand Prix Forum - Welcome Register today! Contact us!

Results 1 to 8 of 8
  1. #1
    SE Level Member
    Join Date
    Aug 2012
    Location
    olympia
    Posts
    28
    Chats
    0

    Default po341 cam sensor help!

    Im stumped. I've got a misfire through the whole rpm range. It runs mostly very poor except for 2 second spurts where it runs great. Ran the codes and got a cam sensor code and have a pre-existing evap and thermostat code. I bought a new cam sensor and installed it...no change. I took one from another gtp, installed it, no change. I unplugged it, no change. Checked signal wire, power and ground at the ICM harness...all good. Swapped ICM and coils...no change. Now when I test drive the car I dont have any codes at all?

  2. #2
    GTP Level Member wowitsfast's Avatar
    Join Date
    Oct 2014
    Location
    portland oregon
    Posts
    570
    Chats
    507

    Default Re: po341 cam sensor help!

    If its not throwing misfire code its prolly not misfiring. In my case my car would sputter and die and surge. Ended up being a bad MAF and a hole mess of vacuum leaks. With a evap code I would lean to vac leak. Post the code if you would plz. If your vac lines are OEM then its time for new ones (cheap at auto parts store) also the T under the SC snout breaks. Is this why you want to sell your IC parts?
    Just a bunch of junk thrown together http://www.grandprixforums.net/threa...shes-a-runner)

  3. #3
    GTP Level Member wowitsfast's Avatar
    Join Date
    Oct 2014
    Location
    portland oregon
    Posts
    570
    Chats
    507

    Default Re: po341 cam sensor help!

    Oh if your still getting the cam sensor code check the plug and its wires make sure they are not messed up
    Just a bunch of junk thrown together http://www.grandprixforums.net/threa...shes-a-runner)

  4. #4
    SE Level Member
    Join Date
    Aug 2012
    Location
    olympia
    Posts
    28
    Chats
    0

    Default Re: po341 cam sensor help!

    The plug is good and wiring, I tested that. The magnet is still secure in the cam gear as well

  5. #5
    GTP Level Member wowitsfast's Avatar
    Join Date
    Oct 2014
    Location
    portland oregon
    Posts
    570
    Chats
    507

    Default Re: po341 cam sensor help!

    IDK im not very good at zeroing in on a issue but if you have put 2 sensors in and still getting a code and it runs ok for 2 second spurts then i dont think the cam sensor is the issue. However I cant tell you what is either.

    I would post the other codes you have and Scotty or FFDP or another member with similar exp will be able to help you im sure
    Just a bunch of junk thrown together http://www.grandprixforums.net/threa...shes-a-runner)

  6. #6
    SE Level Member
    Join Date
    Aug 2012
    Location
    olympia
    Posts
    28
    Chats
    0

    Default Re: po341 cam sensor help!

    And no, im selling intercooler cause im swithing platforms but keeping the gtp

  7. #7
    GT Level Member
    Join Date
    Sep 2015
    Location
    Cheyenne, WY
    Posts
    291
    Chats
    17

    Default Re: po341 cam sensor help!

    Hmmmm...
    Could the timing chain or the sprocket be an issue?
    2007 Antique Bronze Metalic Grand Prix GT...bone stock.

  8. #8
    SE Level Member
    Join Date
    Aug 2012
    Location
    olympia
    Posts
    28
    Chats
    0

    Default Re: po341 cam sensor help!

    ill take a closer look tomorrow at the sprocket and chain, i'm out of ideas

Similar Threads

  1. Replies: 0
    Last Post: 04-01-2015, 08:30 PM
  2. Replies: 7
    Last Post: 01-31-2015, 07:12 PM
  3. Replies: 0
    Last Post: 07-19-2014, 06:51 PM
  4. Picture request of Coolant Temp Sensor and TPS sensor parts
    By David A Smith in forum Shops and Community Heroes
    Replies: 2
    Last Post: 06-11-2010, 12:05 PM
  5. po341 cam sensor circuit code
    By TorqueAutoMotiv in forum 3.8L V6 Supercharged (L67)(L32)
    Replies: 11
    Last Post: 12-19-2009, 12:07 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •