Pontiac Grand Prix Forums : Grandprix
 

Grand Prix Forums is the premier Pontiac Forum on the internet. Registered Users do not see the above ads. Please Register - It's Free!

Pontiac Grand Prix Forum - Welcome Register today! Contact us!

Results 1 to 9 of 9
  1. #1
    SE Level Member
    Join Date
    Jul 2017
    Location
    Yonkers
    Posts
    4
    Chats
    0

    Default 04 Grand Prix not starting

    I have an 04 Pontiac Grand Prix i'm having car trouble's car won't start due to hot and cold weather I gave the car a complete tuneup i also change the alternator battery ignition coil's and starter I have to turn the key a few times for the car to start and most of the time I hear the starter grinding off the flywheel is there a solution to fix this problem

  2. #2
    Turbo is the way to go. Fivefingerdeathpunch's Avatar
    Join Date
    Sep 2009
    Location
    Rogers, MN
    Posts
    20,405
    Chats
    80634

    Default Re: 04 Grand Prix not starting

    Have you pulled the throttle body and cleaned all the black junk off the back of the throttle blade?

    SMGPFC Member #1

  3. #3
    SE Level Member
    Join Date
    May 2017
    Location
    Wouldn't you like to know
    Posts
    143
    Chats
    222

    Default Re: 04 Grand Prix not starting

    Unplug the MAF as well before even cleaning the throttle body.

    If the car starts normally then you need a new MAF.

    If nothing changes it; cleaning that along with the TB probably wouldn't hurt, either.
    1999 Chevrolet Silverado K1500 Classic Z71 - Intake/Gibson Exhaust - The Daily
    2004 Chevrolet Corvette MRM A4 - AFE S2 Intake/TSP Catless LT's/3" ORX/C6 ZR1 Wheels/Exhaust Tips
    Sold WBody's: '98 GT, '98 GTP, '00 GTP, '03 GTP, '05 GXP

  4. #4
    SE Level Member
    Join Date
    Jul 2017
    Location
    Yonkers
    Posts
    4
    Chats
    0

    Default Re: 04 Grand Prix not starting

    Ok I will try that thanks guys..

  5. #5
    SE Level Member
    Join Date
    Jul 2017
    Location
    Yonkers
    Posts
    4
    Chats
    0

    Default Re: 04 Grand Prix not starting

    Still no change... car will still take a while to start

  6. #6
    GTP Level Member
    Join Date
    Jun 2016
    Location
    Cleveland ohio
    Posts
    560
    Chats
    123

    Default Re: 04 Grand Prix not starting

    Go over all the wiring to the stuff you replaced. make sure nothing is loose and the starter ground is properly attached. There should not be noise from the starter. Pull it again and take a look at the flex plate and make sure all the teeth look good. Make sure you have all the plug wires routed correctly. Did you have these issues before you replaced all that stuff?
    2004 Comp G. parting out, transferring parts to 2007
    2007 Grand Prix GT. Under construction Pacesetter headers, 1.8 roller rockers, Wizair CAI, HPTuned, 3.4pulley, TEP transmission, fuel pump and alt rewire, poly mounts/performance suspension, Impala front brakes drilled and slotted rotors.

  7. #7
    SE Level Member
    Join Date
    Jul 2017
    Location
    Yonkers
    Posts
    4
    Chats
    0

    Default Re: 04 Grand Prix not starting

    No everything looks good .do you think my starter needs to be shamed but what would cause it to not start. I have to sit in my car for like five minutes in order for me to start it up sometimes when it starts up it spotters when that happens I have to shut the car off and started it up again..

  8. #8
    SE Level Member
    Join Date
    Aug 2016
    Location
    CT/RI Border
    Posts
    141
    Chats
    0

    Default Re: 04 Grand Prix not starting

    Is the "no" at the start of your post an answer to if this happened before the tune up?

    It almost sounds like you are describing a lazy/dying fuel pump.

    Did you change the fuel filter and air filter? IIRC the '04 is the only year of the last Gens to have an inline filter and many people forget about it.

    Have you run the tank empty recently? Crap on the bottom can mess up not only the filter, but also the pump.

    Did you clean the throttle body/MAF as was suggested earlier?

    Sent from my ASUS_Z00TD using Tapatalk

  9. #9
    SE Level Member
    Join Date
    Jul 2017
    Location
    Nebraska
    Posts
    1
    Chats
    0

    Default Re: 04 Grand Prix not starting

    HI
    I just bought an 04 with the hard start problem cleaned throttle plate and mass airflow sensor but also did a accelerator/throttle relearn with a Snap On scan tool that cured the problem
    have you tried to give it a little throttle while trying to start it?
    dose it act like it is flooded?
    I have seen 5.3 GM engines come in the shop with an intake gasket leak causing a lean start problem, starts hard and runs rough at an idle.
    hope this helps
    Rod

Similar Threads

  1. Hard Starting 92 Grand Prix 3.1
    By verlando in forum General Grand Prix Discussion
    Replies: 1
    Last Post: 11-03-2012, 10:25 PM
  2. 00' Grand Prix GTP (Build starting)
    By Stinkygrub in forum Members Rides
    Replies: 5
    Last Post: 04-09-2012, 10:48 AM
  3. 04 Grand Prix starting issue...
    By joshuaandrew92 in forum 3.8L V6 Naturally Aspirated (L36)(L26)
    Replies: 4
    Last Post: 08-18-2011, 10:47 PM
  4. 01 grand prix starting problems
    By jerrynorman in forum General Tech Discussion
    Replies: 5
    Last Post: 04-23-2011, 10:08 AM
  5. 92 Grand Prix SE starting problem
    By Jhowie in forum General Tech Discussion
    Replies: 0
    Last Post: 03-17-2011, 09:24 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •