Pontiac Grand Prix Forums : Grandprix
 

Grand Prix Forums is the premier Pontiac Forum on the internet. Registered Users do not see the above ads. Please Register - It's Free!

Pontiac Grand Prix Forum - Welcome Register today! Contact us!

Page 1 of 2 12 LastLast
Results 1 to 20 of 27

Thread: Boost problems

  1. #1
    SE Level Member
    Join Date
    Mar 2015
    Location
    Western North Carolina
    Posts
    57
    Chats
    1

    Default Boost problems

    Hey guys I have a 97 gtp an I'm having some boost problems it's only showing 4.4 lbs of boost on my gauge an my torque app an I can not figure out what is going on with it I've looked up the vacuum diagrams an it looks right an my bbv is hittin the set screw at the very bottom when reving the car an goin down the road an I have no leaks anywhere that I can find the only thing I can think to change now is the map sensor should that cause boost not to show if it's bad I'll list all my mods at the bottom thank you guys

    Xp hot cam
    ls7 lifters
    gen v sc
    gen v lim
    140 # valve springs
    fwi
    3.4 sc pulley
    speed daddy headers
    zzp 1.0 pcm
    ac delete
    all new internals pistons rings crank bearings cam bearings oil pump double roller timing set rods newer trans

  2. #2
    Turbo is the way to go. Fivefingerdeathpunch's Avatar
    Join Date
    Sep 2009
    Location
    Rogers, MN
    Posts
    20,237
    Chats
    80501

    Default Re: Boost problems

    How many KPA's does the MAP read at full throttle?

    Should be upwards of 170-180kpa if you are setup to make around 9-10psi.

    Move your vacuum line source to see if you boost gauge changes.

    Perhaps the BBV is causing this to, unplug it and see if you get more boost.

    SMGPFC Member #1

  3. #3
    Killa Bee Scottydoggs's Avatar
    Join Date
    Aug 2010
    Location
    new jersey
    Posts
    36,469
    Chats
    143917

    Default Re: Boost problems

    pull the vac line from the boost blow off actuator, and un plug it, cap the vac line off. then take a test drive.

    98 Buick Regal GS, F body brakes, Caddy STS wheels, tinted tails L36 bottom end, lightly ported heads, 1.95 roller rockers, headers, 2.8, FSIC, 42 lb injectors, a BrandonHall rebuilt trans, DHP tuned and AEM water/Meth injection https://goo.gl/gpV5kW

  4. #4
    SE Level Member
    Join Date
    Mar 2015
    Location
    Western North Carolina
    Posts
    57
    Chats
    1

    Default Re: Boost problems

    Thanks I'll try that in the morning an let ya know Scotty I removed the boost actuator completely already an it still shows the 4 lbs

  5. #5
    Killa Bee Scottydoggs's Avatar
    Join Date
    Aug 2010
    Location
    new jersey
    Posts
    36,469
    Chats
    143917

    Default Re: Boost problems

    make sure that lever moves then, it might be sticking.

    98 Buick Regal GS, F body brakes, Caddy STS wheels, tinted tails L36 bottom end, lightly ported heads, 1.95 roller rockers, headers, 2.8, FSIC, 42 lb injectors, a BrandonHall rebuilt trans, DHP tuned and AEM water/Meth injection https://goo.gl/gpV5kW

  6. #6
    SE Level Member
    Join Date
    Mar 2015
    Location
    Western North Carolina
    Posts
    57
    Chats
    1

    Default Re: Boost problems

    K thanks guys I'll get a video up tomorrow of it an the motor and see if u guys see sum thing I'm not seeing

  7. #7
    SE Level Member
    Join Date
    Mar 2015
    Location
    Western North Carolina
    Posts
    57
    Chats
    1

    Default Re: Boost problems

    Well i switch all the vacuum lines today just in case one was cracked an i by passed the bbv an its still only running at 4lbs i honestly dont know what else to try im getting frustrated with it

  8. #8
    Turbo is the way to go. Fivefingerdeathpunch's Avatar
    Join Date
    Sep 2009
    Location
    Rogers, MN
    Posts
    20,237
    Chats
    80501

    Default Re: Boost problems

    The boost valve itself could be bad, like the diapham inside it.

    SMGPFC Member #1

  9. #9
    Killa Bee Scottydoggs's Avatar
    Join Date
    Aug 2010
    Location
    new jersey
    Posts
    36,469
    Chats
    143917

    Default Re: Boost problems

    spray the top of the engine with carb cleaner, the bbv might have a leak. idle should jump if its leaking.

    98 Buick Regal GS, F body brakes, Caddy STS wheels, tinted tails L36 bottom end, lightly ported heads, 1.95 roller rockers, headers, 2.8, FSIC, 42 lb injectors, a BrandonHall rebuilt trans, DHP tuned and AEM water/Meth injection https://goo.gl/gpV5kW

  10. #10
    SE Level Member
    Join Date
    Mar 2015
    Location
    Western North Carolina
    Posts
    57
    Chats
    1

    Default Re: Boost problems

    Hey ive been super busy at work but i did spray the top of the bbv wit carb cleaner an all around everything they could leak an i never heard the rpms jump up but i got a video finally ill post ot on youtube when i get home an ill post the link an you guys can see if you see something i may be over looking thank you guys for all your help

  11. #11
    SE Level Member
    Join Date
    Mar 2015
    Location
    Western North Carolina
    Posts
    57
    Chats
    1

    Default Re: Boost problems

    Heres the link to a video i had see if you guys see anything i may have over looked thank you guys
    https://m.youtube.com/?reload=7&rdm=2glzk4jx#/my_videos

  12. #12
    SE Level Member
    Join Date
    Mar 2017
    Location
    Internet
    Posts
    85
    Chats
    625

    Default Re: Boost problems

    typically this is the soleniod. aka the electrical piece attached to the bca

  13. #13
    SE Level Member
    Join Date
    Mar 2015
    Location
    Western North Carolina
    Posts
    57
    Chats
    1

    Default Re: Boost problems

    I dont have that peice anymore i took it off when i first started modin the car

  14. #14
    SE Level Member
    Join Date
    Mar 2017
    Location
    Internet
    Posts
    85
    Chats
    625

    Default Re: Boost problems

    pretty safe to rule it out then

  15. #15
    SE Level Member
    Join Date
    Mar 2015
    Location
    Western North Carolina
    Posts
    57
    Chats
    1

    Default Re: Boost problems

    Lol yea i just cant figure out whats causing it i sprayed carb cleaner all over everything an didnt find any leaks any where an i changed all the vacuum lines incase they had any little cracks in them an double checked the vacuum diagram to see if it was gooked up wrong an ot all seemed good i drovenit yesturday an at wot its only showing 4.6lbs of boost i bypassed the bbv completely an it showed around the same maybe lkke .2 or .3 more i know the cam an the headets will take away a little boost but i figured it would be more than 4.5lbs of boost i believe a stock gtp has 6 or 7lbs idk i could be wrong im juat getting real frustrated with it the only other thing i know todo is replace the map sensor an see if maybe it will help other than that im running out of ideas

  16. #16
    Killa Bee Scottydoggs's Avatar
    Join Date
    Aug 2010
    Location
    new jersey
    Posts
    36,469
    Chats
    143917

    Default Re: Boost problems

    stock is like 7-8 psi, add headers your down to 5 on a stock pulley.

    how are you reading your boost? your map might be bad too if your reading it off the obd2.

    98 Buick Regal GS, F body brakes, Caddy STS wheels, tinted tails L36 bottom end, lightly ported heads, 1.95 roller rockers, headers, 2.8, FSIC, 42 lb injectors, a BrandonHall rebuilt trans, DHP tuned and AEM water/Meth injection https://goo.gl/gpV5kW

  17. #17
    Donating Users brettstoner's Avatar
    Join Date
    Jul 2014
    Location
    Toledo, OH
    Posts
    192
    Chats
    0

    Default Re: Boost problems

    Ok so you bypassed the boost control solenoid. The solenoid the ECM uses to dump boost for traction control and reverse. So does the boost bypass valve open and close? Is one end connected to the top of the supercharger and the other open to air? If you manually keep the valve forced closed how much boost builds?
    04 GP GT- top swap, VS cam, 3.0 pulley, E85, headers, 60 injectors, TEP 3:29 trans, ZZP dyno tuned, 300 hp daily driver.

  18. #18
    SE Level Member
    Join Date
    Mar 2015
    Location
    Western North Carolina
    Posts
    57
    Chats
    1

    Default Re: Boost problems

    Yea im reading it off the torque pro app thru the obd2 i have a regular boost gauge but i dont have it hooked up yet its a gen v running a 3.3 pulley brettstoner therea a video link i put up thay shows the bbv moving an the vacuum lines take a look an see if you may see something ive over looked

  19. #19
    Killa Bee Scottydoggs's Avatar
    Join Date
    Aug 2010
    Location
    new jersey
    Posts
    36,469
    Chats
    143917

    Default Re: Boost problems

    that vid link dont work, its like yt home page.

    might want to try another map sensor then.

    is your sc screaming? or is it lacking the whine?

    98 Buick Regal GS, F body brakes, Caddy STS wheels, tinted tails L36 bottom end, lightly ported heads, 1.95 roller rockers, headers, 2.8, FSIC, 42 lb injectors, a BrandonHall rebuilt trans, DHP tuned and AEM water/Meth injection https://goo.gl/gpV5kW

  20. #20
    SE Level Member
    Join Date
    Mar 2015
    Location
    Western North Carolina
    Posts
    57
    Chats
    1

    Default Re: Boost problems

    Ok sorry ill try to post it again it whines but i dont remeber if its as loud as it ahould be ill drive it tomorrow an let you know i really appreciate all you guys help

Page 1 of 2 12 LastLast

Similar Threads

  1. Boost problems
    By BLACKanREDgtp in forum General Tech Discussion
    Replies: 1
    Last Post: 02-20-2017, 10:16 PM
  2. Boost problems
    By BLACKanREDgtp in forum 3.8L V6 Supercharged (L67)(L32)
    Replies: 57
    Last Post: 07-10-2015, 09:28 AM
  3. boost gauge problems
    By 04PrixGTP in forum 3.8L V6 Supercharged (L67)(L32)
    Replies: 34
    Last Post: 07-27-2012, 12:21 AM
  4. 99 Gtp boost problems
    By justrunningagtp in forum 3.8L V6 Supercharged (L67)(L32)
    Replies: 13
    Last Post: 02-24-2012, 04:40 PM
  5. 2005 GTP Comp G Boost problems!
    By 05GTPcmpg in forum 3.8L V6 Supercharged (L67)(L32)
    Replies: 4
    Last Post: 06-03-2011, 11:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •