Pontiac Grand Prix Forums : Grandprix
 

Grand Prix Forums is the premier Pontiac Forum on the internet. Registered Users do not see the above ads. Please Register - It's Free!

Pontiac Grand Prix Forum - Welcome Register today! Contact us!

Page 1 of 3 123 LastLast
Results 1 to 20 of 45
  1. #1
    SE Level Member
    Join Date
    Mar 2015
    Location
    Confederate States of America
    Posts
    52
    Chats
    0

    Default Sat for a couple months. Now multi-codes pending.

    IAC, Throttle position sensor, MAF, transmission pressure valve. All were pending codes after the below incident.

    Haven't driven it for in while and it started poorly and idled rough. Stalled several times. Surging idle. But worse, while driving it on the interstate after 10 minutes it down shifted and revved to about 4k steady RPMs. I got off the interstate and it was shifting hard. Temperature (coolant) was normal the whole time. Parked it for a few hours and drove it again and it behaved better, but rough-ish idle still. Thoughts?

  2. #2
    Killa Bee Scottydoggs's Avatar
    Join Date
    Aug 2010
    Location
    new jersey
    Posts
    36,447
    Chats
    143534

    Default Re: Sat for a couple months. Now multi-codes pending.

    check for damaged wires from critters while it sat. you might find a nest in the air filter box and chewed wires around the engine.

    mice are good like that.

    98 Buick Regal GS, F body brakes, Caddy STS wheels, tinted tails L36 bottom end, lightly ported heads, 1.95 roller rockers, headers, 2.8, FSIC, 42 lb injectors, a BrandonHall rebuilt trans, DHP tuned and AEM water/Meth injection https://goo.gl/gpV5kW

  3. #3
    GT Level Member cheatah faheatah's Avatar
    Join Date
    May 2016
    Location
    rhode island
    Posts
    488
    Chats
    1488

    Default Re: Sat for a couple months. Now multi-codes pending.

    Damn varmits !!
    not what it looks like

  4. #4
    SE Level Member
    Join Date
    Mar 2015
    Location
    Confederate States of America
    Posts
    52
    Chats
    0

    Default Re: Sat for a couple months. Now multi-codes pending.

    Nothing found in the air box and haven't noted any wires that've been chewed yet.

  5. #5
    Killa Bee Scottydoggs's Avatar
    Join Date
    Aug 2010
    Location
    new jersey
    Posts
    36,447
    Chats
    143534

    Default Re: Sat for a couple months. Now multi-codes pending.

    what are all the codes its got? be the best place to start if you cant see any clear damage.

    98 Buick Regal GS, F body brakes, Caddy STS wheels, tinted tails L36 bottom end, lightly ported heads, 1.95 roller rockers, headers, 2.8, FSIC, 42 lb injectors, a BrandonHall rebuilt trans, DHP tuned and AEM water/Meth injection https://goo.gl/gpV5kW

  6. #6
    GT Level Member
    Join Date
    Nov 2015
    Location
    WI
    Posts
    157
    Chats
    0

    Default Re: Sat for a couple months. Now multi-codes pending.

    Could the fuel have gone bad? I dont think it could cause the codes but just throwing it out there.

  7. #7
    SE Level Member
    Join Date
    Mar 2015
    Location
    Confederate States of America
    Posts
    52
    Chats
    0

    Default Re: Sat for a couple months. Now multi-codes pending.

    Quote Originally Posted by Scottydoggs View Post
    what are all the codes its got? be the best place to start if you cant see any clear damage.
    Posted in the OP. Very first line.

    EDIT: The only one "set" has been the issue with the ABS thing, which has always been set.

  8. #8
    Killa Bee Scottydoggs's Avatar
    Join Date
    Aug 2010
    Location
    new jersey
    Posts
    36,447
    Chats
    143534

    Default Re: Sat for a couple months. Now multi-codes pending.

    no the actual codes. not that i dont trust your definitions. but we like to see the code its self. as theres more then one code per item.

    abs wont affect the tranny or how hit runs. thats a separate system.

    98 Buick Regal GS, F body brakes, Caddy STS wheels, tinted tails L36 bottom end, lightly ported heads, 1.95 roller rockers, headers, 2.8, FSIC, 42 lb injectors, a BrandonHall rebuilt trans, DHP tuned and AEM water/Meth injection https://goo.gl/gpV5kW

  9. #9
    SE Level Member
    Join Date
    Mar 2015
    Location
    Confederate States of America
    Posts
    52
    Chats
    0

    Default Re: Sat for a couple months. Now multi-codes pending.

    Now set are: P0121 TP Sensor Range/Performance, and P0101 MAF Sensor Signal Range/Performance.

    Just started and drove it for a code read. The car stalled at the 3rd STOP sign. Ran fairly well (maybe a little stumbling on the interstate) but was uneventful until I came back to gas up from Autozone. It stalled coming off the interstate. Gassed up with 93 then shook it down. It ran well. No stalling.

  10. #10
    Killa Bee Scottydoggs's Avatar
    Join Date
    Aug 2010
    Location
    new jersey
    Posts
    36,447
    Chats
    143534

    Default Re: Sat for a couple months. Now multi-codes pending.

    that maf code is for bad currant to some degree. it could be a bad maf, or fuse #21 blew marked ign in the under hod fuse box.

    a messed up maf can screw with the tranny. if the fuse is good try unplugging the maf, car off, then start it, if it runs better the maf is typically bad.

    the tps can go bad but its kinda rare. what year car you got?

    if the car was cold on your last drive, it runs off the pcm when cold, once warmed up it will want to use the maf, faulty maf and she will act up on ya.

    98 Buick Regal GS, F body brakes, Caddy STS wheels, tinted tails L36 bottom end, lightly ported heads, 1.95 roller rockers, headers, 2.8, FSIC, 42 lb injectors, a BrandonHall rebuilt trans, DHP tuned and AEM water/Meth injection https://goo.gl/gpV5kW

  11. #11
    SE Level Member
    Join Date
    Mar 2015
    Location
    Confederate States of America
    Posts
    52
    Chats
    0

    Default Re: Sat for a couple months. Now multi-codes pending.

    It's a 2000. The #21 fuse, a 15A is good. The car stalled cold and I think was stuttering a bit on the way to A-zone, but not on the way back from code reading. But it stalled coming off the interstate on the way back. Tank was nearing empty and the LOW fuel light has been on. Didn't drive it long after some fresh gas but it didn't stall or behave weird. Going to try it again in a little while on a longer trip.

  12. #12
    Killa Bee Scottydoggs's Avatar
    Join Date
    Aug 2010
    Location
    new jersey
    Posts
    36,447
    Chats
    143534

    Default Re: Sat for a couple months. Now multi-codes pending.

    another trick is to tap the maf while the car idles. if its running poorly it might perk up and run nice when tapped on. maf is the square flat thing a top the tb. the tps is on the rad side of the tb.

    all them wires bake in the exhaust heat and can become damaged, cracks in the insulation or missing insulation. if you see bare wire the pig tail needs to be replaced.

    if it comes down to the maf is bad, best to hit a junk yard and snag one. be much cheaper then new, and oem mafs work best, aftermarket suck in these cars. aka your car will hate it pretty fast. pretty sure thats the same maf from 99-01. its the same part na or sc'ed. part # is on top the maf, so you know what one is right while searching the yard. they are in a lot of gm cars, regals, park avs, impalas and so on. any one with a 3800 engine.

    98 Buick Regal GS, F body brakes, Caddy STS wheels, tinted tails L36 bottom end, lightly ported heads, 1.95 roller rockers, headers, 2.8, FSIC, 42 lb injectors, a BrandonHall rebuilt trans, DHP tuned and AEM water/Meth injection https://goo.gl/gpV5kW

  13. #13
    SE Level Member
    Join Date
    Mar 2015
    Location
    Confederate States of America
    Posts
    52
    Chats
    0

    Default Re: Sat for a couple months. Now multi-codes pending.

    Ok. Have a complete spare engine that should work for that.

  14. #14
    Killa Bee Scottydoggs's Avatar
    Join Date
    Aug 2010
    Location
    new jersey
    Posts
    36,447
    Chats
    143534

    Default Re: Sat for a couple months. Now multi-codes pending.

    even better

    98 Buick Regal GS, F body brakes, Caddy STS wheels, tinted tails L36 bottom end, lightly ported heads, 1.95 roller rockers, headers, 2.8, FSIC, 42 lb injectors, a BrandonHall rebuilt trans, DHP tuned and AEM water/Meth injection https://goo.gl/gpV5kW

  15. #15
    SE Level Member
    Join Date
    Mar 2015
    Location
    Confederate States of America
    Posts
    52
    Chats
    0

    Default Re: Sat for a couple months. Now multi-codes pending.

    Swapped MAF; same problem. No difference. After several minutes of driving it does it again, then acts in a normal manner for a while. When it does it the car smells as though it's starving for fuel when under the hood, but I can rev it to keep it running when at a stop.

  16. #16
    SE Level Member
    Join Date
    Mar 2015
    Location
    Confederate States of America
    Posts
    52
    Chats
    0

    Default Re: Sat for a couple months. Now multi-codes pending.

    Well it tried to burn itself up. On the interstate is where this happens. This time I decided to keep driving and see if it would clear up again Nope. It went to 2nd gear and stuck there. Popping and choking, then the exhaust got very loud, and then louder still and by the time I got to the exit? Smoke. Pulled into a gas station, popped the hood and flames were down low on the pass side between the firewall and trans. Grabbed the station fire extinguisher and that's that. Trailer home. No more problem.

  17. #17
    Killa Bee Scottydoggs's Avatar
    Join Date
    Aug 2010
    Location
    new jersey
    Posts
    36,447
    Chats
    143534

    Default Re: Sat for a couple months. Now multi-codes pending.

    crap-o-la.

    98 Buick Regal GS, F body brakes, Caddy STS wheels, tinted tails L36 bottom end, lightly ported heads, 1.95 roller rockers, headers, 2.8, FSIC, 42 lb injectors, a BrandonHall rebuilt trans, DHP tuned and AEM water/Meth injection https://goo.gl/gpV5kW

  18. #18
    SE Level Member
    Join Date
    Mar 2015
    Location
    Confederate States of America
    Posts
    52
    Chats
    0

    Default Re: Sat for a couple months. Now multi-codes pending.

    Could a clogged exhaust cause something like this? Vandalized gas, like sugar? cracked heads? It had decent power when I threw the pedal down though. Even when it was stuck in 2nd, it was sneezing some but would go pretty good. Just wouldn't shift.

  19. #19
    SE Level Member
    Join Date
    Mar 2015
    Location
    Confederate States of America
    Posts
    52
    Chats
    0

    Default Re: Sat for a couple months. Now multi-codes pending.

    Okay, found out what caused the fire. At the rear of the car the exhaust came off the rear hangers at the very back (left side), tweaking the exhaust coupling right behind the engine at the rear manifold. It caused a leak which got progressively worse over several minutes until it completely detached. That pipe (head pipe?) is just laying on the power steering lines which are above the rack. The high revving exhaust dumping straight out the rear flange ignited the foil/mat heat shielding and oil against the fire wall. The O2 wiring is cooked too. So, it's gonna take a few hours to repair the wiring and exhaust.
    But what is the coupling supposed to look like back there? Meaning the manifold to the head(?) pipe. Anybody have a pic? Stopped by the parts store but we couldn't find an image of what it looks like. Or maybe mine just broke free?

  20. #20
    Killa Bee Scottydoggs's Avatar
    Join Date
    Aug 2010
    Location
    new jersey
    Posts
    36,447
    Chats
    143534

    Default Re: Sat for a couple months. Now multi-codes pending.

    if you just got pipe that fell off, aka no flange, the stock flex broke off. you'll need a new catted down pipe.

    98 Buick Regal GS, F body brakes, Caddy STS wheels, tinted tails L36 bottom end, lightly ported heads, 1.95 roller rockers, headers, 2.8, FSIC, 42 lb injectors, a BrandonHall rebuilt trans, DHP tuned and AEM water/Meth injection https://goo.gl/gpV5kW

Page 1 of 3 123 LastLast

Similar Threads

  1. Car issues couple of fault codes.
    By wakkamis in forum Introductions/Noob Questions
    Replies: 4
    Last Post: 08-31-2015, 10:24 AM
  2. got a couple ses codes, could use some advice
    By hellbilly hippy in forum General Grand Prix Discussion
    Replies: 7
    Last Post: 03-15-2015, 08:32 AM
  3. intake ports after running E85 for a couple months, PICS
    By jdmgtp in forum 3.8L V6 Supercharged (L67)(L32)
    Replies: 4
    Last Post: 01-05-2013, 10:41 PM
  4. Replies: 17
    Last Post: 05-15-2012, 08:37 PM
  5. new motor in now have a couple codes
    By grn97gtp in forum 3.8L V6 Supercharged (L67)(L32)
    Replies: 11
    Last Post: 05-16-2011, 03:06 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •