Pontiac Grand Prix Forums : Grandprix
 

Grand Prix Forums is the premier Pontiac Forum on the internet. Registered Users do not see the above ads. Please Register - It's Free!

Pontiac Grand Prix Forum - Welcome Register today! Contact us!

Results 1 to 12 of 12
  1. #1
    Awesome Level Member chrsmi1's Avatar
    Join Date
    Jan 2013
    Location
    Raleigh, NC
    Posts
    825
    Chats
    651

    Default Went to the track. No traction occured

    Went to the track for a few runs this morning. Nothing at all impressive. No traction whatsoever. Even with nitto 555r tires and launching at 2k.

    Second video show me burning out half way down the track.

    Car pulled super hard once I stopped spinning.

    Left lane both times. Car 220.

    Did beat the trans am. But still...






    Comp G. E85, 2.8, Headers, Tune, Intake, S1X, 105# springs, 60 # injectors, 255 walbro,etc.

    *NEW* 2002 Camaro Z28- Lid, Headers, Catback


  2. #2
    GrandPrix Junkie CrazyGuy03's Avatar
    Join Date
    Jan 2010
    Location
    Buffalo
    Posts
    3,867
    Chats
    7797

    Default Re: Went to the track. No traction occured

    That track looked soaking wet in the video
    2003 Buick Regal GSX lots of mods - click here to see latest build - http://www.grandprixforums.net/threa...ld-for-the-gsx

    *For Reference - Does not have a Zack Howard Cam - It's an Intense Stage 3 - Thank You*

  3. #3
    GTP Level Member
    Join Date
    Mar 2009
    Location
    Pittsburgh
    Posts
    628
    Chats
    0

    Default Re: Went to the track. No traction occured

    2.6 and 2.9 sixty foots

    Driver Mod?
    2003 SSEi,

  4. #4
    Awesome Level Member chrsmi1's Avatar
    Join Date
    Jan 2013
    Location
    Raleigh, NC
    Posts
    825
    Chats
    651

    Default Re: Went to the track. No traction occured

    Quote Originally Posted by 2003 SSEi View Post
    2.6 and 2.9 sixty foots

    Driver Mod?
    Definitely need the driver mod. I haven't been to the track in a year plus, so practice probably would have helped.

    Still thought I would do better with kinda new nittos.
    Comp G. E85, 2.8, Headers, Tune, Intake, S1X, 105# springs, 60 # injectors, 255 walbro,etc.

    *NEW* 2002 Camaro Z28- Lid, Headers, Catback


  5. #5
    Donating Users brettstoner's Avatar
    Join Date
    Jul 2014
    Location
    Toledo, OH
    Posts
    208
    Chats
    0

    Default Re: Went to the track. No traction occured

    How do you like those Nitto 555R tires in general? I was thinking about running them as summer tires. Any feedback?
    Thanks!
    04 GP GT- top swap, VS cam, 3.0 pulley, E85, headers, 60 injectors, TEP 3:29 trans, Racelogic Traction Control, ZZP dyno tuned, 300 hp daily driver.

  6. #6
    Awesome Level Member chrsmi1's Avatar
    Join Date
    Jan 2013
    Location
    Raleigh, NC
    Posts
    825
    Chats
    651

    Default Re: Went to the track. No traction occured

    Quote Originally Posted by brettstoner View Post
    How do you like those Nitto 555R tires in general? I was thinking about running them as summer tires. Any feedback?
    Thanks!
    I won’t buy another set. They didn’t do well either time I took them to the track, they were pretty bad in anything heavier than a light rain, and they’re at least $50 more expensive than normal tires.

    They were only slightly better in keeping the tires from going up in smoke on the street at WOT during low speeds. Basically I’ll smoke the tires on all seasons from like 35 below and with the nittos, it was like 30mph and below and they would go up. Just barely better.

    I took them off for the winter and got some cheap all seasons that I’ll run. Probably won’t put em back on. I’ll just look to get a set of Mickey t’s for track only.
    Comp G. E85, 2.8, Headers, Tune, Intake, S1X, 105# springs, 60 # injectors, 255 walbro,etc.

    *NEW* 2002 Camaro Z28- Lid, Headers, Catback


  7. #7
    Donating Users brettstoner's Avatar
    Join Date
    Jul 2014
    Location
    Toledo, OH
    Posts
    208
    Chats
    0

    Default Re: Went to the track. No traction occured

    Thanks for the feedback. What tire pressure did you run them at?
    04 GP GT- top swap, VS cam, 3.0 pulley, E85, headers, 60 injectors, TEP 3:29 trans, Racelogic Traction Control, ZZP dyno tuned, 300 hp daily driver.

  8. #8
    Awesome Level Member chrsmi1's Avatar
    Join Date
    Jan 2013
    Location
    Raleigh, NC
    Posts
    825
    Chats
    651

    Default Re: Went to the track. No traction occured

    on the street, 26 psi. helped them wear more evenly.

    At the track 20 psi
    Comp G. E85, 2.8, Headers, Tune, Intake, S1X, 105# springs, 60 # injectors, 255 walbro,etc.

    *NEW* 2002 Camaro Z28- Lid, Headers, Catback


  9. #9
    GXP Level Member GTPpower's Avatar
    Join Date
    May 2008
    Location
    Schuyler, NE
    Posts
    2,452
    Chats
    262

    Default Re: Went to the track. No traction occured

    I thought they sucked as well. They really need to be warmed up well to stick at all. I have a set that I ran for awhile. But then I bought slicks and never looked back.

    2001 GTP - cam, headers, nitrous, stock trans - 11.83 @ 116 <$2k in mods - sold
    2005 F350 6.0 - studded, deleted, bulletproofed, tuned
    1966 Olds Cutlass 442 Convertible
    2000 Chevy Silverado 2500 6.0l

  10. #10
    Donating Users brettstoner's Avatar
    Join Date
    Jul 2014
    Location
    Toledo, OH
    Posts
    208
    Chats
    0

    Default Re: Went to the track. No traction occured

    Thanks! Looks like I will stick to my summer tires and pass on these. 25 psi street and 18 psi strip seem to be pretty popular pressures in the F Body crowd. Looks like your pressures were right on.
    Last edited by brettstoner; 01-25-2017 at 09:57 AM.
    04 GP GT- top swap, VS cam, 3.0 pulley, E85, headers, 60 injectors, TEP 3:29 trans, Racelogic Traction Control, ZZP dyno tuned, 300 hp daily driver.

  11. #11
    Donating Users 16MustangVet's Avatar
    Join Date
    May 2009
    Location
    Sh1t hole Afghanistan Currently
    Posts
    5,443
    Chats
    49253

    Default Re: Went to the track. No traction occured

    they call them SH1TTOS for a reason.....
    How I treat my car: wreck,fix, repeat.

  12. #12
    Admin blueguy's Avatar
    Join Date
    Jun 2008
    Location
    Dirtyzville, Missery
    Posts
    31,404
    Chats
    77762

    Default Re: Went to the track. No traction occured

    Yeah, everyone I've ever ran across have always had to hit the burnout box quite a bit before ever hoping to get Nitto's to grab.
    Sold WBody's: '03 Blue GTP/'98 Green GTP/'98 Silver GT/'05 GXP
    '99 Chevrolet Silverado Classic Z71 4x4 - K&N Intake/Gibson Exhaust #TRUCKTHINGS
    '12 Buick Regal Turbo - ZZP CAI/20% Tint/HID's
    '89 Ford Mustang LX Notchback - LM7 5.3, 4L80, 9", HX40
    '04 Chevrolet Corvette MRM A4/LS1 - TSP LT's, 3"O/R X, AFE S2 CAI

Similar Threads

  1. More traction!!
    By suitercrew in forum Tires & Wheels
    Replies: 7
    Last Post: 01-25-2017, 10:05 AM
  2. Replies: 2
    Last Post: 05-11-2016, 01:58 PM
  3. Traction control light only traction control
    By ccoimbre in forum General Grand Prix Discussion
    Replies: 0
    Last Post: 02-09-2014, 01:02 PM
  4. ABS and Traction Control not working but no ABS or Traction Control lights
    By jruether11 in forum Brakes/Suspension/Chassis
    Replies: 2
    Last Post: 02-22-2013, 04:40 AM
  5. traction
    By m3ta77ica in forum Tires & Wheels
    Replies: 17
    Last Post: 10-24-2009, 03:06 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •